Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Unable to access SSH



I'm using mac to access. I tried to ssh to the system, but failed.


I tried:


and used my username and password for godaddy.


After a few tries, seems like the server blocked me. I received:

ssh_exchange_identification: read: Connection reset by peer


Can someone help me?




Helper V

Re: Unable to access SSH



Hello there,

I use a program called, "putty", for ssh access . Not sure if I ever used that handy little button g/d gave us........

Hope this bumps your question up in line......

Mrsroadrunner Photography

Re: Unable to access SSH

Hey @cinsiong,


First let me say welcome to the community! Smiley Happy


Sounds like you might be using your account login information for the customer account and not the one specified for your hosting plan. Those are usually separate. Just in case, you might try a reset


If you're still seeing an issue with SSH access after trying this, you may want to reach out to our live support so our hosting team can look at the account directly to see what's preventing access.


CG - GoDaddy | Community Moderator
24/7 support available at

Re: Unable to access SSH

None of any reply helps!


I am having the same problem. After several times try. My server blocked me, since I can access SSH from another computer. I consult a lot of godaddy support, they are totally not helpful. I am now trying to back up all files from my server and restart over it. Godaddy didn't write everything clearly and we have to figure it out by ourself!!!! (On gateway page, settings, you can restart your server.)


Re: Unable to access SSH

Also, I am not sure whether that way would help. If I restart over the server and everything screw me up again, I will hit my glass!


Re: Unable to access SSH

Yeah, I agree with you Ricky, I am having the exactly same problem and I tried a few times to speak with the support team and they don't know what to do, they just say it will be investigated for one of our engineer and after that the issue still there and they didn't do anything. Also, one time they told me that ssh won't be necessary, if I have access to the FTP which it is a totally wrong answer from a support guy.


I also, tried to explain them that the issue is not with access to the control panel or FTP,  the real issue is because the server for some reason after you fail 3 times to access though ssh, it blocks you.


So they should be able to  verify the firewalls o iptables and remove our IP from there and add our IPs to a white list.



Re: Unable to access SSH

Another one having the exact same issue.


I speak with GoDaddy and they blame my ISP. I speak with my ISP and they blame GoDaddy.


Very frustrating.

Re: Unable to access SSH

CG is correct, but the problems I ran into is that it was not obvious what user I was supposed to be using. I always logged into godaddy with my account information and I never used the login info that you are apparently supposed to use for ssh.

But the account info you are supposed to be using is the Special FTP Account. CG is right about how to reset the password, but you have to go here to find the username.


But you'll probably still have to call and get your IP unblocked if you are getting the "connection reset by peer" error


Re: Unable to access SSH

i am also facing same problem. how do you solve this

Re: Unable to access SSH

+1 same problem here 


Nothing helps.. not even ssh keys


Re: Unable to access SSH

Yes! use Primary ID user can access ssh without problem now! 



Re: Unable to access SSH


I had exactly the same problem yesterday and was on a 'chat' with support for about 2 hours.

I was using Putty as my PC client.  I use cPanel on godaddy.

In short what I did (some with the direction of support)

- Activate SSH (cPanel->SSH Access)

- Create a public key for SSH

- Change Settings (Manage my account -> Setting button)

- Select Password tab

- Change the Password for the account (I took over the site from someone else and he didn't have the site's password)

- Identify the username for the account

- cPanel -> Files ->FTP Accounts

- The username for the site is under Special FTP Accounts  It is under Log In column and has a path pointing to your home directory

- Obtain site's IP address (cPanel->Website(s) IP Address)

- Using Putty:

     - IP address in the Host Name (or IP address)

     - Port 22

     - Connection Type SSH


Hope this helps.



Re: Unable to access SSH

In the last few days I've started getting an error message from ssh and sftp when I try to connect to my GoDaddy-hosted Web site: "Unable to negotiate with port 22: no matching host key type found. Their offer: ssh-dss"

So I looked that message up and found which says

1) the "right" answer is for the host to upgrade its encryption to something stronger than ssh-dss, but

2) if you can't wait for that, you can add "HostKeyAlgorithms +ssh-dss" to the relevant host entry in your .ssh/config file


I did #2, and am now able to get into my account again, but it sounds like somebody at GoDaddy Web Hosting would need to take care of #1.

Re: Unable to access SSH

I had the same problem. I use the Mac 'Terminal' to log onto the server with:



I found a solution here. By doing this it worked:

"ssh -oHostKeyAlgorithms=+ssh-dss".

Unable to access SSH

Hi , 

I have purchased new server and created server on 13-feb-2017 , I was able to login using username ,

but now I am unable to login it is asking every time,'s password:


even if I i give correct user and pwd , its not working.

01. I am able to access from (WHM)

02. I enabled root access on my account

03. I restarted my server couple of times 


please help.


Re: Unable to access SSH

I also had this same problem after upgrading my server for more resources.  Now, I am unable to login via SSH.




Re: Unable to access SSH


im trying to modify the code of my websites online from my laptop using git but i have the next error


Unable to negotiate with 5x.xx.xx.1 port 22: no matching host key type found. Their offer: ssh-dss
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.


The repository exist and i did the conexion...
git remote add origin

dont know if this is correct or not

anyone can help me to sort this out once and for all?.

thanks a lot

Re: Unable to access SSH

I am having same issue.  I am unable to get WinSCP working.  I created a key pair, and am using the special FTP name without a password.  I cannot get in.  Am I doing it wrong or is there something GoDaddy is doing that makes this not possible?

Re: Unable to access SSH

I have been trying to connect Putty via SSH as I require composer to develop my Drupal site. 

I have set up my FTP accounts and have been using Filezilla with one account so it is working. I have also set up another in the process of trying to get this to work.

I now try and connect to the same account using Putty. I use the website I.P and leave the port at 22 (when I change port to 21 which matches the FTP config it will not connect) to connect then at the prompt I enter the correct FTP account name and then the correct Password. Then it tells me access denied. 

I have not had to use SSH access before and I am finding this rather confusing and hard to get help from the help desk on. It is slowing my whole project. Anyone have any possible solutions. Thanks.

Community Manager
Community Manager

Re: Unable to access SSH

Hi @CMG_Webmaster, what type of server are you using, and are you getting any particular error message?



Re: Unable to access SSH

I am using a linux server. 


Re: Unable to access SSH

Could you please explain the steps to setting up this connection using Putty.

I require the use of Composer for development of my Drupal sites.

Re: Unable to access SSH

Unable to access my web site and also unable to ping it.



Re: Unable to access SSH

Thanks for posting your message, it helped me.  


I was able to ssh to godaddy from work.  I called tech support for the 5th or 6th night in a row, and insisted they were blacklisting me.  I talked to Armando and he was able to fix it quickly.  


The first few calls, the godaddy tech would ssh in themselves, from godaddy (a white-listed ip address) and reported no problems.  So the test itself was misleading.  They concluded it was a problem on my end but it wasn't.


I asked them to add that to the help system, that "Connection reset by peer" means that


(a) godaddy is terminating the connection, not the client.

(b) it may mean the user tried to log in too many times badly, and was blacklisted.


It sounds overly sensitive, 3 strikes and you're out.  So be careful with those passwords!!!




Re: Unable to access SSH

I just want to reinforce what juraj said, and maybe provide some pointers for talking to tech support, if you get the "connection reset by peer" error over SSH.


Just yesterday, I made a few failed attempts to SSH into my GoDaddy server (as I'm just learning how to do it), and started getting the "connection reset by peer" error.  I called tech support (choose the menu option to talk to tech support about "Hosting" or "Security"), and calmly explained, "I'm just learning how to use SSH to connect to my server. I think I used the wrong login credentials a few times, before I figured out what I was doing wrong. Now it looks like my IP is blacklisted. Could you please check on that, and see if you can remove the block on my IP?"


The tech support rep checked on some basic stuff that I had already checked myself: making sure I had enabled SSH in my hosting account settings, making sure I had an active Public Key in cPanel > SSH Access, asking if I had reset my password recently, etc.  I allowed him to go through the motions.  Then I told him that I was able to SSH into the server if I turned on my VPN (virtual private network), but not when using my public IP.  I could tell that this issue was getting outside of his personal knowledge (and I'm the one who's just learning the stuff!), but didn't call him out on it.  After a moment, he said he would reach out to his "tech support lead," who would be more familiar with this issue.


The tech lead had him ask for my public IP (by visiting  They checked it against their database/blacklist/whatever, and sure enough, my IP had been automatically blocked by GoDaddy after 3 failed login attempts over SSH.  The tech lead reset the connection, or refreshed it, or whitelisted the IP, or whatever it is they do, and within seconds I was able to connect via SSH from my public IP.


Yes, it's frustrating when you tell them exactly what the problem is, and they still have to go through the whole rigamarole just to reach the same conclusion, but if you can keep calm and back up your story with whatever facts you know about the situation, they'll eventually get there.  If not, see if they can ask their tech support lead about it. Smiley Wink

Re: Unable to access SSH

Yep, call hosting support (480-463-8308) or main number (ext 2 ext 4), and tell them your IP was blacklisted due to too many failed login attempts, and ask them to run a tool they have internally to unblock your IP. Just did it and it works fine now.


P.S. Don't call SSL and Security support, you'd think that'd be the right way to go, but they couldn't reproduce the error, and therefore wouldn't help me.