• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    Fatal error: fatal flex scanner internal error--end of buffer missed in /home/content/20/7071920/htm

    Hello. Today, when I tried to go Into my site that's hosted by GoDaddy - it's a wordpress site - I'm getting the following error:

     

    Fatal error: fatal flex scanner internal error--end of buffer missed in /home/content/20/7071920/html/wp-config.php on line 36

     

    As far as I know, nothing has been changed other than an update was automatically done on 11/29 via an email I got.  It was updated to WordPress 4.9.1.

     

    I cannot get to the site nor can I get to the wpadmin part of the site to even backout any of these updates.

     

    Please help!!!

    1 REPLY 1

    Re: Fatal error: fatal flex scanner internal error--end of buffer missed in /home/content/20/7071920

    Hey Harterkc,

    I found this thread that seems to have helped a lot of people.

    http://johnlamansky.com/tech/php-fatal-flex-scanner-internal-error/

     

    At the very end of it they suggest:

     

    "I got the same error message but I can’t acess anything anymore, I can’t even log in on my wordpress panel to change the code.

    1. What do I do??

      The message I get is the following one Fatal error: fatal flex scanner internal error–end of buffer missed in /home/compl962/public_html/wp-content/themes/accesspress-lite/functions.php on line 104"

       

      **What he says** ---------------------

      John Lamansky

      You’ll have to use an FTP client, or your web host’s file manager in the control panel, to rename the “accesspress-lite” folder. That will disable your current theme so you can log in to your WordPress again.

      ----------------

      Then elsewhere in the thread they mention that in one of the related files there is/are unclosed comment/s. A missing */ or what 

       
      Thiago Moskito October 29, 2013 at 4:37 pm clarifies:

      Change all lines beginning with:

      /**

      to

       /*

      only that!

      (I sent find and replace on all the files and go!)
      example:

      /**  <------ should be 1 * not 2. (don't include this comment..;)
      * Lorem ipsum
      * Lorem ipsum dolor
      * Ipsum sit amet
      */

      should be:

      /*
      * Lorem ipsum
      * Lorem ipsum dolor
      * Ipsum sit amet
      */

       

      Anyway, it's all in that thread.. I'm sick of dealing with my problems so this was a nice break..;) Hope what all those other guys wrote helps..;)

       

      Best,

      Craig Ryder