cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Cannot get website with G suite domain working

Hi,

 

I bought domain over G Suite, but provider is already Go Daddy. 

I have built my own web site and bought hosting on Go Daddy, now I cannot connect domain with hosting and get my website working. 

Instructions in G Suite are very unclear or are missing key elements like what IP to use, what CNAME should I use and where do I get name servers? 

In my go daddy account I do not see any domain, despite I have domain in G Suite, but registrar was Go Daddy. 

In cPanel I already uploaded everything, but there is no instructions how to I connect web page with domain from G Suite. Domain is listed in cPanel, but nothing is working. 

1 ACCEPTED SOLUTION

@Matejp 

 

I would try a private browser - when I goto http://digitopia.info/ the site is loading and the domain remains in the address bar - I would also check the DNS for a CNAME for www pointed to @

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

14 REPLIES 14
Super User IV

@Matejp 

 

What is your domain so I can take a look at the DNS to get you going in the right direction

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

My domain is: digitopia.info

 

Thanks.

@Matejp 

 

So your domain is actually registered with GoDaddy through Google Suite - If you  goto https://support.google.com/a/answer/4377734?hl=en there should be an username / password - if you log into that GoDaddy account (I suggest using a private browsing window) you should be able to get to the DNS for your domain and update the IP record to point to the hosting in your other account.

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

I'm really confused now with all this IPs and DNS stuff. So I should put hosting IP from hosting account into DNS of GSuite domain account? 

@Matejp 

That is correct - 

 

Google uses GoDaddy and a few others when you register a domain via Google Suite - When they do this they create a GoDaddy account where the domain lives.

 

So you have 

1) GoDaddy account where your hosting is (I assume same one you've logged into the Community with)

2) GoDaddy account via Google - This account is where your domain is and where you go to be able to update the DNS information

 

When you go into the account where the domain is you want to make sure you only have 1 @ record which is the main IP for the domain

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Ok I have done that, but there are still 2 problems:

- now I have two A type records there. One I added and is pointing to go daddy server and one I cannot change pointing somewhere else. Is this ok?

- entering url of web page into browser now redirects to IP directly. Shouldn't there be name of page (domain)? And also page is still not loading. 

@Matejp 

 

You may want to see if there is a template applied to the domain - that is the only thing I can think of - You should only have 1 A @ record

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Interesting, that today I had only 2 A records, one was pointing to go daddy hosting IP and one said "parked". I deleted parked one and now there is only one record pointing to hosting IP. But page still doesn't work as it should and I still get redirected to raw IP in browser instead of having domain name there... 

@Matejp 

 

I would try a private browser - when I goto http://digitopia.info/ the site is loading and the domain remains in the address bar - I would also check the DNS for a CNAME for www pointed to @

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

I get "Invalid URL" and nothing works... this is starting to frustrate me. 

@Matejp 

This seems to be working fine here.

When I did a look up for www.digitopia.info. 3599 IN CNAME uk.godaddy.com.

The CNAME should be @ not uk.godaddy.com

 

ScreenShot.png

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Ok looks like now it is working, but only if I put www in front of it. Without it it doesn't work. Should there also be redirect set?

@Matejp 

 

As I said you need to change the CNAME from uk.godaddy.com to @

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Ok thanks, it seems it is working now.