Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Domain not in my account

I ordered two .uk domains on Sunday, and received emails on Monday saying they'd been successfully registered, and would be in my account. But only one of them appeared in my account.


Then on Tuesday I received another email, telling me the missing domain had been successfully registered. But it's still not in my account.


If I go to the DNS page, and type in the first letter of the missing domain, it appears there, but if I try to add a host record I get an error message saying "Domains must be in an eligible status."


It's as though the domain is stuck in limbo somewhere.


I tried to contact Godaddy via chat, but just got a "Chat loading..." message, without it loading. I'm not able to contact them by phone.


Does anyone know how to fix this problem?


Super User III
Super User III

Re: Domain not in my account



The only resolution to this particular issue is to contact phone support or live chat. If you're still having issues with live chat, try opening up the GoDaddy site in an incognito/private window.

I am a GoDaddy End User - Just Like You
* Please note that I DO NOT answer private messages. Please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. If you contact me via PM for help, I will give you a price quote for my personal services. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community