Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

GoDaddy Website not working

Hi there


I am a new customer - just bought a new domain from GoDaddy. However, minutes after joining, I cannot access any page on the GoDaddy website any more, except for these community forums.


The error message I keep getting is:

Access Denied

You don't have permission to access "" on this server.

Reference #18.b4e7f648.1534764037.10c0b5e9


It is not just me - my co-workers in the office also cannot access the website any more. What is surprising that I can ping "" and can also run a tracert to ""


I've also tried clearing my browser cache and cookies, have also tried using multiple browsers as well - Chrome, MSFT Edge, Firefox - but cannot access the website at all.


Could someone help?



Hi @robert_pierce,


Thanks for posting. I'd recommend testing access from a different network, if the issue continues you should contact support so they can investigate the issue. 



Lisi - GoDaddy | Community Moderator | 24/7 support available at | Remember to choose a solution and give kudos.