cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution

Office 365 Woocommerce Emails Wordpress Not Working

I have recently migrated from CPanel Linux hosting to WordPress hosting through Go Daddy. Why I have no idea how as it's only caused issues! 

 

Previously, we used a workspace email hosted by Go Daddy. In order to receive emails from WooCommeerce regarding new orders via the Wordpress website, I had to install an SMTP plugin. Since transferring to 365 emails this no longer works.  

 

I have spoken to GoDaddy, who are of NO help! They say you cannot use an SMTP plugin it is against our protocol and also say it's a Woocommerce bug. When looking up Woocommerce forums they suggest installing a SMTP plugin as it's a hosting issue. So basically going around in circles. 

 

The current error message on the SMTP plugin is: 

SMTP ERROR: Failed to connect to server: Connection refused (111)SMTP connect() failed

 

I am using the following settings: 

 

SMTP Host: smtp.office365.com

Type of Encryption: SSL/TLS

SMTP Port: 25

SMTP Username & Password as per my email log ins. 

 

This appears to be an FAQ yet I am failing to find a solution on Go Daddy, Wordpress and Woocommerce forums - HELP! 

 

 

1 REPLY 1
Community Manager
Community Manager
Solution

Re: Office 365 Woocommerce Emails Wordpress Not Working

Hi @Banjaarayoga. Thanks for being part of GoDaddy Community! Unfortunately, you wouldn't be able to relay emails via your Office 365 account. You really shouldn't have been able to do it via a Workspace Email account either, which is strange. In this situation, you'll want to use the following SMTP options instead:

  • SMTP Host: relay-hosting.secureserver.net

  • SMTP Port: 25

  • SMTP Username & Password: Leave this blank. It's not needed when sending from a hosting plan. 

I'd leave out any settings for SSL/TLS at first. If the connection works, you can try adding it after that. 

 

Another thing you'll want to make sure of is that your domain has the following in its SPF record:

 

v=spf1 include:secureserver.net –all

Your domain probably has the record "v=spf1 include:spf.protection.outlook.com -all". You'll want to remove that and replace it with the one above. Hope this helps. 

 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.