Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't upload media - Failed to write file to disk and HTTP error


I have looked all over the internet for a solution and there are a lot of suggestions, but none seem to be the right fix or are very extreme. Can someone please help me.


Problem Overview
I have several live WordPress websites. There is 1 primary domain and several other domains hosted on the same server.


The “Upload New Media” function simply stopped working a few days ago. The Primary Domain was the only one not affected. I get Failed to write file to disk. or HTTP. errors respectively.

I contacted GoDaddy Hosting Support for help. They said all was working on the server and made a few changes to test for a solution. They could not solve the problem, but now the error is occuring on the primary domain too.


Below are the specs for my various environments

  • WordPress sites are all hosted with GoDaddy.
  • Programming Language PHP 5.6.
  • Running on an unlimited bandwidth/traffic option.
  • Tested on Google Chrome and IE, same error.
  • WordPress 4.8, theme Enfold (4.1.2) and plugins are all up to date and disabled.

Steps I’ve taken so far

Several separate websites using the same Wordpress settings, theme, plugins and PHP version are running as normal on two other hosting provider's servers.


I hadn’t made any updates to the website’s WordPress versions, theme or plugins before the errors on all but the primary domain started.


What Did Change

I updated the PHP version from 5.4 to 5.5 in addition to what the support people at GoDaddy did. After those two actions the Primary Domain began giving the same error as all the others.


I would really appreciate help. I am feeling a little desperate as these sites are well trafficked and content is regularly updated.

Helper VI

@Mac007 That's odd. Since you followed that tutorial I'd assume it's not a permission issue.

You say you changed the PHP version. Can you post what libraries you have active? You can check it on the "Select PHP version" option within cpanel.


Hope it helps!

If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄



Thank you for getting back to me. GoDaddy support ran a repair script on the server which sorted the problem out.


Pro Tip: It saves a lot of wasted time and effort if you simply ask them to run it on the first support call.  Smiley Wink

@Mac007 Glad to hear that!



If you find my replies helpful, give me a like or kudo 🙂
And if I solved your issue, mark it as solution 😄