I can't SSH nor SFTP to my WordPress server anymore...

So I've chatted with GoDaddy support twice and no one has been able to help me and has considered my issue to be SOL.


Up until a couple days ago, I was about to SSH and SFTP onto both production and staging to push changes to a WordPress theme I'm working on. Now. Every time I try to SSH or SFTP, the connection times out. Yes, I am able to ping both sites.


Some possible relevant factors:

*The last SFTP upload I made broke the theme and I am no longer about to get the WP admin. I am trying to SFTP again so I can fix the issue but you can see how that's going...

*I also updated to the latest security patch released by Apple but I really don't think that's related. I tried ssh on another Mac (that did not update to that patch) and it still yields the same results.

*I am able to SSH just fine to my A2 Hosting server (not using port 22) and I can SFTP into my other GoDaddy Shared Hosting account (also not using port 22).


It'd be great to get actual help with this issue since it's keeping me from developing from a client. If all else fails, I'll just recommend changing hosting services. 

Community Team
Community Team

Have you tested the connections from a different network to see if you're able to access the server that way?  I'd recommend trying that out to see if you get the same result.  You may also want to try running a traceroute to the server to see if there are any indicators as to why the connections are timing out.  




I am having the exact same issue. Use to be able to access my Wordpress site via SFTP and now it keeps timing out. Go Daddy was trying to say it was my ISP, but I can SFTP into another Go Daddy account that is not managed via word press just fine. I think Go Daddy has done something on their end. Did you ever get a resolution to this issue? I'm still having the problem.

Helper III
Helper III

Hi @metalandcoffee,


This is the same issue I dealt with for the last year and a half.  See this thread.




For myself it is now working since they modified the data packet size on the server cluster our managed wordpress site is hosted on.  Reference tech support to this thread and ask them if they have done the same on your site's server cluster.


If they have and it still isn't working then pretty much you are out of options.  I had a year and half of misery before they fixed this issue for me.


Good luck.



View solution in original post